Yamaha CA-1010 Amplifier – owner opinions and more

Rather than pollute the NS-1000 thread further, I thought I’d start one specific to the Yammy amp.

From my previous post:

=====
Well, I won’t be going rackless after all, I don’t think!

After a frustrating hour and a half hunting for a pair of speaker cables to use with the amp (can one fit modern banana terminals to these amps?), I ended up having to make up a pair from some basic old QED cable. Anyway, that was all sorted.

There’s a synergy at work here I guess, with the CA-1010 and NS-1000Ms, that produces a very organic sound that I’m really loving. I’m not keen on words like ‘organic’ in this context, but I can’t think of any better one to summarise. Bass seems more enveloping, and upper mids have a greater delicacy. It sounds more real.

Of course, it has loads of knobs and switches, 90% of which are of no value to me!

But, it also has two VU meters that mesmerise with their largely synchronised swaying against subtle backlights.

This amp is a delight.
======

The amp remains a delight in principle, but is exhibiting some distortion in the left channel this evening. :(

I’ve contacted @toprepairman , and hopefully he’ll be able to sort it out.

Part of my reason for posting this thread is to document my journey into Classic-Amplifier-Land, but also to ask for any reassurance that you learned folk might be able to give!

I obviously turned it off immediately I noticed the distortion, and it’s not going back on until fixed.

Continues HERE